Upgrade installation 2

From Wiki_EAI
Jump to navigation Jump to search

Make sure you have a working Mail server using the base installation and skipped Upgrade installation 1.


Install php5-cli, the script is using PHP

sudo apt-get install php5-cli

get the script and place it in /etc/postfix

   https://github.com/padillareyj/eaifilter/blob/master/eaifilter.php


This filter will check outgoing mail server, if the server does not support SMTPUTF8, it rewrites the address of the sender to a non-ascii format base on alias mapping.

smtp      inet  n       -       -       -       -       smtpd -o content_filter=eaifilter -o receive_override_options=no_header_body_checks
eaifilter unix - n n - - pipe flags=RXhu user=nobody argv=/etc/postfix/eaifilter.php -f ${sender} -d ${recipient}
127.0.0.1:10025   inet  n       -       n       -       -        smtpd
        -o content_filter=
        -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks,no_milters
        -o smtpd_helo_required=no
        -o smtpd_helo_restrictions=
        -o smtpd_data_restrictions=
        -o smtpd_client_restrictions=
        -o smtpd_sender_restrictions=
        -o smtpd_recipient_restrictions=permit_mynetworks,reject
        -o mynetworks_style=host
        -o in_flow_delay=0

Update main.cf

content_filter =eaifilter:[127.0.0.1]:10025